2.1.3 Compile Problem with libsbsms-system-libraries

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

2.1.3 Compile Problem with libsbsms-system-libraries

Klaumi Klingsporn
Dear developers,

trying compile audacity-2.1.3 with system-libraries of libsbsms
(instead of the local copy in the mini-src-tar) gives me an error:

"configure:21184: $PKG_CONFIG --exists --print-errors "sbsms >= 2.2.0"
Requested 'sbsms >= 2.2.0' but version of sbsms is 2.0.2"

And infact the system-version of libsbsms is 2.0.2, but as far as I
see there exists no newer one, at least not at
https://sourceforge.net/projects/sbsms/files/sbsms/.

And the local copy of libsbsms also claims to be 2.0.2, at least
in audacity-minsrc-2.1.3/lib-src/sbsms/libsbsms.spec:

"%define name    libsbsms
%define version 2.0.2
%define release 5"

So, is this only a typo in the configure-script (2.2.0 instead of
2.0.2) or is there a real reason for this?

Klaumi


-----------
Klaus-Michael Klingsporn
mail: [hidden email]
web: www.klaumikli.de


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
audacity-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/audacity-devel
Reply | Threaded
Open this post in threaded view
|

Re: 2.1.3 Compile Problem with libsbsms-system-libraries

Stevethefiddle
The version used by Audacity is ahead of the Sourceforge version. The
developer of this library (Clayton Otey) added a couple of bug fixes
about a year ago, which he was intending to also add upstream, but it
seems that he's not got round to that yet, or Sourceforge is no longer
the upstream repository.

Steve

On 10 April 2017 at 14:32, Klaumi Klingsporn <[hidden email]> wrote:

> Dear developers,
>
> trying compile audacity-2.1.3 with system-libraries of libsbsms
> (instead of the local copy in the mini-src-tar) gives me an error:
>
> "configure:21184: $PKG_CONFIG --exists --print-errors "sbsms >= 2.2.0"
> Requested 'sbsms >= 2.2.0' but version of sbsms is 2.0.2"
>
> And infact the system-version of libsbsms is 2.0.2, but as far as I
> see there exists no newer one, at least not at
> https://sourceforge.net/projects/sbsms/files/sbsms/.
>
> And the local copy of libsbsms also claims to be 2.0.2, at least
> in audacity-minsrc-2.1.3/lib-src/sbsms/libsbsms.spec:
>
> "%define name    libsbsms
> %define version 2.0.2
> %define release 5"
>
> So, is this only a typo in the configure-script (2.2.0 instead of
> 2.0.2) or is there a real reason for this?
>
> Klaumi
>
>
> -----------
> Klaus-Michael Klingsporn
> mail: [hidden email]
> web: www.klaumikli.de
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> audacity-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/audacity-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
audacity-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/audacity-devel