Audacity 1.3.13 build fails on Ubuntu 10.04 LTS

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Audacity 1.3.13 build fails on Ubuntu 10.04 LTS

Luchka
Hi!
I'm trying to build Audacity 1.3.13 rev 11135 downloaded from SVN on Ubuntu 10.04 LTS with wxGTK 2.8.11 built with flags --enable-unicode --enable-debug --enable-gtk2, but I get this error:

In file included from AudacityApp.cpp:70:
FFmpeg.h: In function ‘void av_free_packet(AVPacket*)’:
FFmpeg.h:764: error: redefinition of ‘void av_free_packet(AVPacket*)’
/usr/include/libavformat/avformat.h:211: error: ‘void av_free_packet(AVPacket*)’ previously defined here
FFmpeg.h: In function ‘int av_fifo_generic_read(AVFifoBuffer*, void*, int, void (*)(void*, void*, int))’:
FFmpeg.h:775: error: declaration of C function ‘int av_fifo_generic_read(AVFifoBuffer*, void*, int, void (*)(void*, void*, int))’ conflicts with
/usr/include/libavutil/fifo.h:73: error: previous declaration ‘int av_fifo_generic_read(AVFifoBuffer*, int, void (*)(void*, void*, int), void*)’ here
make[1]: *** [AudacityApp.o] Error 1
make[1]: Leaving directory `/home/luca/audacity-read-only/src'
make: *** [audacity] Error 2

Reading this post:
http://audacity.238276.n2.nabble.com/rev11087-build-fails-td6257590.html

I found a patch named ffmpeg-stable.ptch for FFmpeg, tried to apply it, then patch command told me: Reversed (or previously applied) patch detected!
So the patch seems to be useless for my version of Audacity....?
I also tried to build beta 1.3.13 downloaded from Audacity website, same problem....

Any idea??
Many thanks!

Reply | Threaded
Open this post in threaded view
|

Re: Audacity 1.3.13 build fails on Ubuntu 10.04 LTS

Luchka
Sorry, I forgot to mention that I'm working on a 64-bit OS.
Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Audacity 1.3.13 build fails on Ubuntu 10.04 LTS

Luchka
In reply to this post by Luchka
Nobody?