Quantcast

XCode 3.2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

XCode 3.2

Darrell Walisser

I was unable to build Audacity today using 10.7 and Xcode 3.2.3. This configuration was working as early as Sept of last year when I last tried it.

The reason for the break seems to be some compiler flags were added (looks like to disable warnings only) that are not recognized.

Anyways I thought I would let you guys know. It isn't critical for me to get this to work, but I would like to have a test environment to validate the crosscompile patch set (pr #161) on OS X.

If this change was planned let me know the minimum Xcode version being supported.

Thanks,
Darrell

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
audacity-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/audacity-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: XCode 3.2

Gale
Administrator
Your Xcode must support the 10.6 SDK, which is our minimum SDK
now.

Xcode 4.3.3 should work, but building on Lion hasn't been tested in
a long time.

Also see https://github.com/audacity/audacity/blob/master/mac/Build.txt
which works for building on recent macOS (certainly, El Capitan and
Sierra).


Gale Andrews


On 8 February 2017 at 15:55, Darrell Walisser
<[hidden email]> wrote:

>
> I was unable to build Audacity today using 10.7 and Xcode 3.2.3. This
> configuration was working as early as Sept of last year when I last tried
> it.
>
> The reason for the break seems to be some compiler flags were added (looks
> like to disable warnings only) that are not recognized.
>
> Anyways I thought I would let you guys know. It isn't critical for me to get
> this to work, but I would like to have a test environment to validate the
> crosscompile patch set (pr #161) on OS X.
>
> If this change was planned let me know the minimum Xcode version being
> supported.
>
> Thanks,
> Darrell
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> audacity-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/audacity-devel
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
audacity-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/audacity-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: XCode 3.2

Darrell Walisser
Yes, I did the 10.6 sdk.

cc1: error: unrecognized command line option "-Wno-inconsistent-missing-override"
cc1: error: unrecognized command line option "-Wno-potentially-evaluated-expression"

g++ -v says 4.2.1 (llvm 2326.10)


 Has anyone tried the OSX environment on Travis-CI ?


On Wed, Feb 8, 2017 at 2:47 PM, Gale Andrews <[hidden email]> wrote:
Your Xcode must support the 10.6 SDK, which is our minimum SDK
now.

Xcode 4.3.3 should work, but building on Lion hasn't been tested in
a long time.

Also see https://github.com/audacity/audacity/blob/master/mac/Build.txt
which works for building on recent macOS (certainly, El Capitan and
Sierra).


Gale Andrews


On 8 February 2017 at 15:55, Darrell Walisser
<[hidden email]> wrote:
>
> I was unable to build Audacity today using 10.7 and Xcode 3.2.3. This
> configuration was working as early as Sept of last year when I last tried
> it.
>
> The reason for the break seems to be some compiler flags were added (looks
> like to disable warnings only) that are not recognized.
>
> Anyways I thought I would let you guys know. It isn't critical for me to get
> this to work, but I would like to have a test environment to validate the
> crosscompile patch set (pr #161) on OS X.
>
> If this change was planned let me know the minimum Xcode version being
> supported.
>
> Thanks,
> Darrell
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> audacity-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/audacity-devel
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
audacity-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/audacity-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
audacity-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/audacity-devel
Loading...